aboutsummaryrefslogtreecommitdiff
path: root/package/qt5/qt5declarative/Config.in
blob: a1fb9a310274548e65915b208320620db0294bb3 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
config BR2_PACKAGE_QT5DECLARATIVE_AVAILABLE
	bool
	# Javascript engine is only available on certain architectures
	depends on BR2_arm || BR2_i386 || BR2_x86_64 || BR2_mipsel
	# ARM needs BLX, so v5t+
	depends on !(BR2_arm7tdmi || BR2_arm720t || BR2_arm920t || BR2_arm922t || BR2_fa526)
	default y

config BR2_PACKAGE_QT5DECLARATIVE
	bool "qt5declarative"
	select BR2_PACKAGE_QT5XMLPATTERNS
	select BR2_PACKAGE_QT5BASE
	select BR2_PACKAGE_QT5BASE_GUI
	select BR2_PACKAGE_QT5BASE_EGLFS
	depends on BR2_PACKAGE_HAS_OPENGL_EGL
	depends on BR2_PACKAGE_HAS_OPENGL_ES
	depends on BR2_PACKAGE_QT5DECLARATIVE_AVAILABLE
	help
	  Qt is a cross-platform application and UI framework for
	  developers using C++.

	  This package corresponds to the qt5declarative module.

	  http://qt-project.org

comment "qt5declarative requires an OpenGL-capable backend"
	depends on (!BR2_PACKAGE_HAS_OPENGL_EGL || !BR2_PACKAGE_HAS_OPENGL_ES) && \
		BR2_PACKAGE_QT5DECLARATIVE_AVAILABLE