aboutsummaryrefslogtreecommitdiff
path: root/package/qt5/qt5quickcontrols/Config.in
blob: 265132823f7567f8d0e93c87561c722f06a1d6e9 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
config BR2_PACKAGE_QT5QUICKCONTROLS
	bool "qt5quickcontrols"
	select BR2_PACKAGE_QT5BASE
	select BR2_PACKAGE_QT5BASE_NETWORK
	select BR2_PACKAGE_QT5DECLARATIVE
	depends on BR2_PACKAGE_QT5DECLARATIVE_AVAILABLE
	depends on BR2_PACKAGE_HAS_OPENGL_EGL
	depends on BR2_PACKAGE_HAS_OPENGL_ES
	help
	  Qt is a cross-platform application and UI framework for
	  developers using C++.

	  This package corresponds to the qt5quickcontrols module.

	  http://qt-project.org

comment "qt5quickcontrols requires an OpenGL-capable backend"
	depends on (!BR2_PACKAGE_HAS_OPENGL_EGL || !BR2_PACKAGE_HAS_OPENGL_ES) && \
		BR2_PACKAGE_QT5DECLARATIVE_AVAILABLE