aboutsummaryrefslogtreecommitdiff
path: root/package/qtopia4/Config.in
blob: 7a702c6d7b2364f1f2b62e0bac58d9bd6953ac87 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
config BR2_PACKAGE_QTOPIA4
	bool "qtopia4"
	depends on BR2_INSTALL_LIBSTDCPP
	help
	  Qtopia core 4.

	  http://www.trolltech.com/

comment "qtopia4 requires a toolchain with C++ support enabled"
	depends on !BR2_INSTALL_LIBSTDCPP

if BR2_PACKAGE_QTOPIA4

config BR2_PACKAGE_QTOPIA4_DEBUG
	bool "Compile with debug support"
	help
	  If unsure, say N.

choice
	prompt "Library type"
	default BR2_PACKAGE_QTOPIA4_SHARED
	help
	  Selects the library type: Shared or Static

config BR2_PACKAGE_QTOPIA4_SHARED
	bool "Shared library"
	help
	  Create and use shared Qt libraries.
	  If you have multiple programs that depend on Qt or intend to use
	  plugins, say Y.

config BR2_PACKAGE_QTOPIA4_STATIC
	bool "Static Library"
	help
	  Create and use static Qt libraries.
	  If you don't have multiple programs on the target that depends on
	  Qt, then this will save you quite some of storage space.
	  If unsure, say Y.

endchoice

config BR2_PACKAGE_QTOPIA4_LICENSE_TYPE_COMMERCIAL
	bool "Use commercial license"

config BR2_PACKAGE_QTOPIA4_LICENSE_APPROVED
	bool "Approve free license"
	depends on !BR2_PACKAGE_QTOPIA4_LICENSE_TYPE_COMMERCIAL
	help
	  Select this if you approve one of the available free licenses for the
	  Qt4 library.
	  By doing this you will not be asked while the library is compiled.
	  Please read and understand the license terms before approving this.

	  LGPL v2.1: http://doc.trolltech.com/4.5/lgpl.html
	  GPL  v3.0: http://doc.trolltech.com/4.5/gpl.html

config BR2_PACKAGE_QTOPIA4_COMMERCIAL_USERNAME
	string "Qtopia Core 4 Commercial License Username"
	depends on BR2_PACKAGE_QTOPIA4_LICENSE_TYPE_COMMERCIAL
	help
	  Commercial users can download their source directly by
	  providing a username.

config BR2_PACKAGE_QTOPIA4_COMMERCIAL_PASSWORD
	string "Qtopia Core 4 Commercial License Password"
	depends on BR2_PACKAGE_QTOPIA4_LICENSE_TYPE_COMMERCIAL
	help
	  Commercial users can download their source directly by
	  providing a password.

config BR2_PACKAGE_QTOPIA4_QT3SUPPORT
	bool "Compatibility with Qt3"
	help
	  Turns on support for older Qt3. This will create an additional
	  library with proxy code and increase the space required on target.
	  If unsure say n.

config BR2_PACKAGE_QTOPIA4_GUI_MODULE
	bool "Gui Module"
	default y
	help
	  Turns on support to Gui applications. If your board don't have
	  video output, or you don't require Qt GUI, say n.

if BR2_PACKAGE_QTOPIA4_GUI_MODULE
menu "Pixel depths"
comment "Deselecting each option leads to Qt's default (8,16,32)"

config BR2_PACKAGE_QTOPIA4_PIXEL_DEPTH_ALL
	bool "All supported depths"

if !BR2_PACKAGE_QTOPIA4_PIXEL_DEPTH_ALL

config BR2_PACKAGE_QTOPIA4_PIXEL_DEPTH_1
	bool "1 bpp, black/white"

config BR2_PACKAGE_QTOPIA4_PIXEL_DEPTH_4
	bool "4 bpp, grayscale"

config BR2_PACKAGE_QTOPIA4_PIXEL_DEPTH_8
	bool "8 bpp, paletted"
	default y

config BR2_PACKAGE_QTOPIA4_PIXEL_DEPTH_12
	bool "12 bpp, rgb 4-4-4"

config BR2_PACKAGE_QTOPIA4_PIXEL_DEPTH_15
	bool "15 bpp, rgb 5-5-5"

config BR2_PACKAGE_QTOPIA4_PIXEL_DEPTH_16
	bool "16 bpp, rgb 5-6-5"
	default y

config BR2_PACKAGE_QTOPIA4_PIXEL_DEPTH_18
	bool "18 bpp, rgb 6-6-6"

config BR2_PACKAGE_QTOPIA4_PIXEL_DEPTH_24
	bool "24 bpp, rgb 8-8-8"

config BR2_PACKAGE_QTOPIA4_PIXEL_DEPTH_32
	bool "32 bpp, argb 8-8-8-8 and rgb 8-8-8"
	default y

endif
endmenu
endif

config BR2_PACKAGE_QTOPIA4_GIF
	bool "Enable GIF support"
	depends on BR2_PACKAGE_QTOPIA4_GUI_MODULE
	help
	  This compiles and installs the plugin for GIF reading support.

config BR2_PACKAGE_QTOPIA4_LIBMNG
	bool "Enable libmng support"
	depends on BR2_PACKAGE_QTOPIA4_GUI_MODULE
	help
	  This compiles and installs the plugin for MNG support.

choice
	prompt "JPEG support"
	depends on BR2_PACKAGE_QTOPIA4_GUI_MODULE
	default BR2_PACKAGE_QTOPIA4_NOJPEG
	help
	  Select libjpeg support.

config BR2_PACKAGE_QTOPIA4_NOJPEG
	bool "No jpeg support"
	help
	  Disable JPEG support

config BR2_PACKAGE_QTOPIA4_SYSTEMJPEG
	select BR2_PACKAGE_JPEG
	bool "System libjpeg"
	help
	  Link against system libjpeg

config BR2_PACKAGE_QTOPIA4_QTJPEG
	bool "Use Qt bundled libjpeg"
	help
	  Link against libjpeg proveded with Qt
endchoice

choice
	prompt "PNG support"
	depends on BR2_PACKAGE_QTOPIA4_GUI_MODULE
	default BR2_PACKAGE_QTOPIA4_NOPNG
	help
	  Select which library to use if PNG support should be enabled.

config BR2_PACKAGE_QTOPIA4_NOPNG
	bool "No PNG support"

config BR2_PACKAGE_QTOPIA4_SYSTEMPNG
	bool "System libpng"
	select BR2_PACKAGE_LIBPNG

config BR2_PACKAGE_QTOPIA4_QTPNG
	bool "Use Qt bundled libpng"
endchoice

choice
	prompt "TIFF support"
	depends on BR2_PACKAGE_QTOPIA4_GUI_MODULE
	default BR2_PACKAGE_QTOPIA4_NOTIFF
	help
	  Select which library to use if TIFF support should be enabled.

config BR2_PACKAGE_QTOPIA4_NOTIFF
	bool "No TIFF support"

config BR2_PACKAGE_QTOPIA4_SYSTEMTIFF
	bool "System libtiff"
	select BR2_PACKAGE_TIFF

config BR2_PACKAGE_QTOPIA4_QTTIFF
	bool "Use Qt bundled libtiff"
endchoice

choice
	prompt "zlib support"
	default BR2_PACKAGE_QTOPIA4_QTZLIB
	help
	  Select zlib support.

config BR2_PACKAGE_QTOPIA4_QTZLIB
	bool "Qt zlib"
	help
	  Use the zlib bundled with Qt.

config BR2_PACKAGE_QTOPIA4_SYSTEMZLIB
	bool "System zlib"
	select BR2_PACKAGE_ZLIB
	help
	  Use the shared zlib from the system.
endchoice

choice
	prompt "freetype2 support"
	depends on BR2_PACKAGE_QTOPIA4_GUI_MODULE
	default BR2_PACKAGE_QTOPIA4_NOFREETYPE
	help
	  Select freetype2 support.

config BR2_PACKAGE_QTOPIA4_NOFREETYPE
	bool "no freetype2 support"
	help
	  Do not compile in Freetype2 support.


config BR2_PACKAGE_QTOPIA4_QTFREETYPE
	bool "Qt freetype2"
	help
	  Use the libfreetype bundled with Qt.

config BR2_PACKAGE_QTOPIA4_SYSTEMFREETYPE
	bool "System freetype2"
	select BR2_PACKAGE_FREETYPE
	help
	  Use shared libfreetype from the target system.
	  See http://www.freetype.org/
endchoice

config BR2_PACKAGE_QTOPIA4_EMB_PLATFORM
	string "The embedded platform we are making Qtopia4 for"
	default "arm"	if BR2_arm
	default "arm"	if BR2_armeb
	default "avr32"	if BR2_avr32
	default "x86"	if BR2_i386
	default "x86_64"	if BR2_x86_64
	default "mips"	if BR2_mips
	default "mips"	if BR2_mipsel
	default "ppc"	if BR2_powerpc
# Not that I really believe these will work..
	default "generic"	if BR2_alpha
	default "generic"	if BR2_chris
	default "generic"	if BR2_m68k
	default "generic"	if BR2_nios2
	default "generic"	if BR2_sh
	default "generic"	if BR2_sh64
	default "generic"	if BR2_sparc
	help
	  The target platform.

source "package/qtopia4/Config.sql.in"
if BR2_PACKAGE_QTOPIA4_GUI_MODULE
source "package/qtopia4/Config.gfx.in"
source "package/qtopia4/Config.mouse.in"
endif

config BR2_PACKAGE_QTOPIA4_PHONON
	bool "Phonon Module"
	select BR2_PACKAGE_GSTREAMER
	select BR2_PACKAGE_GST_PLUGINS_BASE
	help
	  Build the Phonon module. Support for different audio/video
	  formats can be configured at the GStreamer package.
	  If unsure, say n.

config BR2_PACKAGE_QTOPIA4_XML
	bool "XML Module"
	default y
	help
	  Build the XML module.

config BR2_PACKAGE_QTOPIA4_XMLPATTERNS
	bool "XML Patterns Module"
	depends on BR2_PACKAGE_QTOPIA4_XML
	help
	  Build QtXmlPatterns module.
	  If unsure, say n

config BR2_PACKAGE_QTOPIA4_SVG
	bool "SVG Module"
	help
	  Build the SVG module.
	  If unsure, say n

config BR2_PACKAGE_QTOPIA4_NETWORK
	bool "Network Module"
	default y
	help
	  Install the Network module.
	  if unsure, say y

config BR2_PACKAGE_QTOPIA4_WEBKIT
	bool "WebKit Module"
	depends on BR2_PACKAGE_QTOPIA4_NETWORK
	help
	  Build the WebKit module.
	  If unsure, say n.

config BR2_PACKAGE_QTOPIA4_OPENSSL
	bool "Enable OpenSSL support"
	depends on BR2_PACKAGE_QTOPIA4_NETWORK
	select BR2_PACKAGE_OPENSSL
	help
	  Enable support for the OpenSSL encryption library. If you use
	  QSslSocket say y here, otherwise, say no to save space on the
	  target.
	  If unsure, say n.

config BR2_PACKAGE_QTOPIA4_SCRIPT
	bool "Script Module"
	default y
	help
	  Build the Qt Script module.
	  if unsure, say y.

config BR2_PACKAGE_QTOPIA4_SCRIPTTOOLS
	bool "Script Tools Module"
	depends on BR2_PACKAGE_QTOPIA4_SCRIPT
	default n
	help
	  Build the Qt Script Tools module.
	  if unsure, say n.

endif # BR2_PACKAGE_QTOPIA4