aboutsummaryrefslogtreecommitdiff
path: root/toolchain/kernel-headers/Config.in
blob: 1d27021a696a411fe936156f37edb8039d2f4084 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
# Choose the kernel headers to use for kernel-headers target. This is
# ignored if you are building your own kernel or using the system kernel.
#

menu "Kernel Header Options"

choice
	prompt "Kernel Headers"
	default BR2_KERNEL_HEADERS_2_6_22
	help
	  Select the version of kernel header files you wish to use.
	  You must select the correct set of header files to match
	  the kernel you intend to use on your target system.

	config BR2_KERNEL_HEADERS_2_4_25
		depends !BR2_avr32 && !BR2_nios2 && BR2_DEPRECATED
		bool "Linux 2.4.25 kernel headers"

	config BR2_KERNEL_HEADERS_2_4_27
		depends !BR2_avr32 && !BR2_nios2 && BR2_DEPRECATED
		bool "Linux 2.4.27 kernel headers"

	config BR2_KERNEL_HEADERS_2_4_29
		depends !BR2_avr32 && !BR2_avr32 && !BR2_nios2 && BR2_DEPRECATED
		bool "Linux 2.4.29 kernel headers"

	config BR2_KERNEL_HEADERS_2_4_31
		depends !BR2_avr32 && !BR2_nios2 && BR2_DEPRECATED
		bool "Linux 2.4.31 kernel headers"

	config BR2_KERNEL_HEADERS_2_6_9
		depends !BR2_avr32 && BR2_DEPRECATED
		bool "Linux 2.6.9 kernel headers"

	config BR2_KERNEL_HEADERS_2_6_11
		depends !BR2_avr32 && BR2_DEPRECATED
		bool "Linux 2.6.11 kernel headers"

	config BR2_KERNEL_HEADERS_2_6_12
		depends !BR2_avr32 && !BR2_nios2 && BR2_DEPRECATED
		bool "Linux 2.6.12 kernel headers"

	config BR2_KERNEL_HEADERS_2_6_20
		depends !BR2_avr32 && !BR2_nios2 && BR2_DEPRECATED
		bool "Linux 2.6.20 kernel headers"

	config BR2_KERNEL_HEADERS_2_6_21
		depends !BR2_avr32 && !BR2_nios2
		bool "Linux 2.6.21.x kernel headers"

	config BR2_KERNEL_HEADERS_2_6_22
		depends !BR2_nios2
		bool "Linux 2.6.22.x kernel headers"

endchoice

config BR2_KERNEL_HEADERS_IPMI
	bool "use ipmi kernel patches"
	default n
	depends BR2_KERNEL_HEADERS_2_6_20 || BR2_KERNEL_HEADERS_2_6_21 || BR2_KERNEL_HEADERS_2_6_22
	help
	  Apply patches which add IPMI sensor support.

config BR2_KERNEL_HEADERS_LZMA
	bool "use lzma initramfs kernel patches"
	default n
	depends BR2_KERNEL_HEADERS_2_6_21 || BR2_KERNEL_HEADERS_2_6_22
	help
	  Apply patches which allow for lzma compressed
	  initramfs filesystems.  This requires the lzma
	  program in your development environment.

config BR2_KERNEL_HEADERS_PATCH_DIR
	bool "Add additional headers from $(KERNEL_HEADERS_PATCH_DIR)"
	default n
	depends BR2_KERNEL_HEADERS_2_6_20 || BR2_KERNEL_HEADERS_2_6_21 || BR2_KERNEL_HEADERS_2_6_22
	help
	  Apply additonal kernel patches defined by KERNEL_HEADERS_PATCH_DIR
	  in your board directory.

config BR2_DEFAULT_KERNEL_HEADERS
	string
	default "2.4.25"    if BR2_KERNEL_HEADERS_2_4_25
	default "2.4.27"    if BR2_KERNEL_HEADERS_2_4_27
	default "2.4.29"    if BR2_KERNEL_HEADERS_2_4_29
	default "2.4.31"    if BR2_KERNEL_HEADERS_2_4_31
	default "2.6.9"     if BR2_KERNEL_HEADERS_2_6_9
	default "2.6.11"    if BR2_KERNEL_HEADERS_2_6_11
	default "2.6.12"    if BR2_KERNEL_HEADERS_2_6_12
	default "2.6.20.19"  if BR2_KERNEL_HEADERS_2_6_20
	default "2.6.21.7"  if BR2_KERNEL_HEADERS_2_6_21
	default "2.6.22.6"  if BR2_KERNEL_HEADERS_2_6_22

endmenu