aboutsummaryrefslogtreecommitdiff
path: root/toolchain/kernel-headers/Config.in
blob: 2c1c8e2cca8f3d2e0ab9f64513bdb50bce048555 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
# Choose the kernel headers to use for kernel-headers target. This is
# ignored if you are building your own kernel or using the system kernel.
#

comment "Kernel Header Options"

choice
	prompt "Kernel Headers"
	default BR2_KERNEL_HEADERS_2_6_32

	help
	  Select the version of kernel header files you wish to use.
	  You must select the correct set of header files to match
	  the kernel you intend to use on your target system.

	  For the snapshot, you have to provide the
	  linux-2.6.tar.bz2 tarball in your download dir.

	config BR2_KERNEL_HEADERS_2_6_26
		depends on BR2_DEPRECATED
		bool "Linux 2.6.26.x kernel headers"

	config BR2_KERNEL_HEADERS_2_6_27
		depends on BR2_DEPRECATED
		bool "Linux 2.6.27.x kernel headers"

	config BR2_KERNEL_HEADERS_2_6_28
		bool "Linux 2.6.28.x kernel headers"
		depends on BR2_DEPRECATED

	config BR2_KERNEL_HEADERS_2_6_29
		bool "Linux 2.6.29.x kernel headers"
		depends on BR2_DEPRECATED

	config BR2_KERNEL_HEADERS_2_6_30
		bool "Linux 2.6.30.x kernel headers"
		depends on BR2_DEPRECATED

	config BR2_KERNEL_HEADERS_2_6_31
		bool "Linux 2.6.31.x kernel headers"
		depends on BR2_DEPRECATED || BR2_RECENT

	config BR2_KERNEL_HEADERS_2_6_32
		bool "Linux 2.6.32.x kernel headers"

	config BR2_KERNEL_HEADERS_VERSION
		bool "Linux 2.6 (manually specified version)"

	config BR2_KERNEL_HEADERS_SNAP
		bool "Local Linux snapshot (linux-2.6.tar.bz2)"
endchoice

config BR2_KERNEL_HEADERS_RT
	bool "use realtime (-rt) kernel patches"
	depends on BR2_KERNEL_HEADERS_2_6_26
	help
	  Apply Ingo's realtime extensions to linux

config BR2_DEFAULT_KERNEL_VERSION
	string "linux version"
	depends on BR2_KERNEL_HEADERS_VERSION
	help
	  Specify the version you want to use.
	  E.g.: 2.6.31.2

config BR2_DEFAULT_KERNEL_HEADERS
	string
	default "2.6.26.8"	if BR2_KERNEL_HEADERS_2_6_26
	default "2.6.27.45"	if BR2_KERNEL_HEADERS_2_6_27
	default "2.6.28.10"	if BR2_KERNEL_HEADERS_2_6_28
	default "2.6.29.6"	if BR2_KERNEL_HEADERS_2_6_29
	default "2.6.30.10"	if BR2_KERNEL_HEADERS_2_6_30
	default "2.6.31.12"	if BR2_KERNEL_HEADERS_2_6_31
	default "2.6.32.9"	if BR2_KERNEL_HEADERS_2_6_32
	default "2.6"		if BR2_KERNEL_HEADERS_SNAP
	default $BR2_DEFAULT_KERNEL_VERSION if BR2_KERNEL_HEADERS_VERSION